RouterBoard 上 ChangeIP 的 DDNS script

ChangeIP 上申請好一筆 DDNS 名稱後,接下來就是要設定到家中的 RB 上
萬一有 PPPoE 重新連線的時候,RB 可直接連上 ChangeIP 上更新 IP

用 WinBox 連上 RB 後,從 System > Scheduler 中,新增一筆
RouterBoard 上 ChangeIP DDNS script
其中的 Interval 的單位為 時:分:秒,如果第一次設定,想要更快確認是否有更新,可先設 00:03:00
阿嘉只是有空有連進去看看我的 RB 狀態而已,有時候一忙也沒想要連,才設定 01:00:00
其中這幾行的需要改掉
:local ddnsuser "CHANGEIP_USERNAME"   //CHANGEIP_USERNAME 替換成 ChangeIP 網站的登入帳號
:local ddnspass "CHANGEIP_PASSWORD"  //CHANGEIP_PASSWORD 替換成 ChangeIP 網站的登入密碼
:local ddnshost "CHANGEIP_YOUR_DOMAIN_NAME"   //CHANGEIP_YOUR_DOMAIN_NAME 替換成 ChangeIP 上的 DDNS名稱
:local ddnsinterface "WAN_INTERFACE" //WAN_INTERFACE  替換成 RB 上 PPPoE 的介面名稱

完整的 Scheduler script
:local ddnsuser "CHANGEIP_USERNAME"
:local ddnspass "CHANGEIP_PASSWORD"
:local ddnshost "CHANGEIP_YOUR_DOMAIN_NAME"
:local ddnsinterface "WAN_INTERFACE"
# 以上資訊要填寫好,這條是註解!
:global ddnslastip
:global ddnsip [ /ip address get [find interface=$ddnsinterface disabled=no] address ]
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }

:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.") } else={
:if ($ddnsip != $ddnslastip) do={
:log info "DDNS: Sending UPDATE!"
:log info [ /tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ]
:global ddnslastip $ddnsip } else={
:log info "DDNS: No change" }
}

這個網誌中的熱門文章

線上看 CAD 圖檔 DWG, DWF 的網站

開箱 ASUS RT-AC51U 及 USB 共用手機 4G上網

網卡 MAC address 製造商查詢